ODA Patching from 12.1.2.6.0 to 12.1.2.7.0 failed.

+ ODA VM version upgrade 12.1.2.6.0 to 12.1.2.7.0

+ node0 patch successfully , but node1 patch failed

+ following did not help
# oakcli update –patch 12.1.2.7.0 –clean
# oakcli update -patch 12.1.2.7.0 –server

# oakcli update –patch 12.1.2.7.0 –clean
# oakcli update -patch 12.1.2.7.0 –server –local

+ Later checked the logs & found

INFO: 2016-09-22 14:11:22: It may take upto 15 mins. Please wait…
ERROR: 2016-09-22 14:17:20: Unable to apply gi patch on the following Homes : /u01/app/12.1.0.2/grid
SUCCESS: 2016-09-22 14:17:20: Successfully started the Database consoles
SUCCESS: 2016-09-22 14:17:20: Successfully started the EM Agents
ERROR: 2016-09-22 14:17:21: Unable to apply the GRID patch
ERROR: 2016-09-22 14:17:21: Failed to patch server (grid) component
INFO: local patching code END
ERROR: 2016-09-22 14:17:21:  Unable to apply the patch on /u01/app/12.1.0.2/grid

File does not exist: /tmp/PatchSummary_1_20160922140336.xml at /opt/oracle/oak/pkgrepos/System/12.1.2.7.0/bin/pkg_install.pl line 2063
ERROR: Unable to apply the patch <2>

+ verified all patch level, patches, rolling state looks good.

+ noticed eventhough CRS was stopped, 2 active orarootagent.bin processes were running

+ killed those processes helped to proceed with ODA patching.

+ One possible cause could be following, but this is not the case here

ODA: Grid Infrastructure (GI) Patching Fails On The Second Node (Doc ID 2118723.1

Advertisements

Author: jee

Oracle Engineered Guy work for Oracle Corp. Techno-addict for Exadata, SuperCluster, ODA, RAC, ASM, HA.Fusion Music Enthusiast,Son,Husband,Father, Information-news- Freak, Optimist, Humanist. Interests : Technology, Innovation, Sharing interesting content. Views expressed on this account are my own and don't necessarily reflect the views of Oracle & its affiliates.